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 ​New &​ ​Improved 
This TILOS release includes these new features and enhancements: 

Tasks and Scheduling 

● Add a file link using a task template​ - When you create a task template, you can now 
link to a file on the File Links tab by clicking + and selecting the file. Then when you 
create a new task in an Integrated view with that task template, the file link is included. 

BIM Integration with Trimble Connect 

Using the TILOS to Connect integration (introduced in version 10.3), you can now also: 

● Do more in the Trimble Connect Setup dialog​ - Select Tools > Trimble Connect > 
Setup Connection to: 

○ See what has changed in Connect more easily​ - Set the Highlight task 
changes color to make unaccepted changes in the list easier to distinguish. 

○ Export data from more fields​ - By default, the TILOS-Connect data exchange is 
limited to basic data (task ID, name, start/end dates, and start/end locations). To 
include other types of information, add Additional fields as desired. 

○ Include descriptions and instructions​ - In the Comment field, select the field 
you are using to add notes and other descriptive information. 

● Synchronize data and download changes from Connect​  - Click buttons to: 
○ Upload Data​ - Click Synchronize Data to push data (as you configured it in the 

Manage Content dialog) to Trimble Connect. 
○ Download Changes​ - Click Download Changes to pull new/modified data (as 

identified by the Property Set Service) from Connect into TILOS. 

● See all Connect changes in a new view​ - In TILOS Explorer, right-click Views > New 
View, and select Connect Changes as the type of view. In the Connect Changes view, 
you can then select Web changes to see the list of tasks created or modified in Connect. 
Use these options to cull the list by: 

○ Not accepted​ - See the changes made in Connect that are not yet in TILOS. To 
bring this change in, right-click the row and select Accept changes. 

○ All tasks​ - See tasks that appear in either TILOS or Connect, regardless of 
whether they have been synchronized or not. 

○ Accepted in last <x> days​ - Shorten the list of recently accepted tasks by time 
frame. 

○ Selected filter​ - Apply a TILOS task filter to the list. 
○ Changes tab​ - See a summary of changes made to any selected task. 
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● Bring changed tasks into focus in an Integrated View​ - When you open the Task 
List, you can click any task that is highlighted (using the Highlight task changes color 
described above) to bring it into focus in the active view. Review the attributes in the 
Object Properties pane, in particular on the Web Changes tab.Then return to the Task 
List to accept the changes to the task as needed. 

● Refresh TILOS with new changes made in Connect​ - In the Trimble Connect Setup 
dialog, click Refresh from Server to bring in updates from Connect. Changes you make 
in TILOS are refreshed in Connect automatically.  

● Do more with TILOS data In Trimble Connect​ - You can now: 
○ Visualize your TILOS schedule ​- When you export project data to Connect, a 

2D ‘PDF’ print of your TILOS schedule appears in Connect as well; this plan is 
juxtaposed with your 3D model so you can see your data in a familiar way. You 
can pan and zoom in to the schedule in Connect, but you cannot edit it.  

○ Review changes from TILOS​ - Select a task and click the Info pane to see any 
new/modified properties pushed from TILOS.  

○ Edit tasks from TILOS ​- Click the Edit icon to make changes to attributes, 
including the percentage of Progress. 

○ Comment on attributes to communicate a task/element group​ - Use the  
Comment field inside the Properties panel to see object attributes so that you 
can discuss task/element grouping without having to leave the panel. 
Comments are 'running,' similar to social media, so that you will see all 
comments that have been made, with the most recent on top. You can also add 
callouts (based on a Trimble notification system) so can send a message directly 
to a recipient. For example, you can enter a comment that says: “@<username>, 
make this task two days longer.”  Your colleague will get the message. 

See the Getting Started with Bim document in the  ​TILOS User Community​ for more 
information. 

Mass Haulage 

● R​emove tasks connected to a haulage when the haulage area is deleted​ - When you 
select and delete a haulage, all connected tasks are removed (after you confirm the action). 

● Keep haulage area and tasks in sync ​- When changing a KP on a specific haulage area, 
the same changes are now applied to tasks associated with the area. 

● Update haul distances when changing the mass balance point on a cut/fill area​ - 
When you change the mass balance point on a specific cut area, the haul distance on the 
haulage is automatically recalculated and the cut and fill task’s haul distance is updated. 
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 ​Fixed 
This TILOS release also includes fixes for reported or discovered cases in which: 

Setups and Projects 

● Project files from earlier versions (6.x or 7.x, 10.2x, and 10.3x) could not be converted 
and would crash the program immediately upon opening. (TIL-1093, TIL-1059) 

● Project files from earlier versions (10.1x) would hang/freeze the program after 
changing the view scaling. (TIL-1073) 

● You could make changes to a project and close it without being prompted to save the 
changes; this resulted in your changes being lost. (TIL-1047) 

Import/Export/Data Exchange 

● Anomalies in calendar names prevented all tasks from being exported to Microsoft​Ⓡ 
(MS) Project. (TIL-1078) 

● Some task links were not properly exported to MS Project, e.g., successor links were 
missing. (TIL-1044) 

● Improperly formatted and non-unique task ID values in a custom text field caused 
circular dependency errors (“ERROR - Loop detected. Tasks in the loop…”) when 
importing a schedule from MS Project. (TIL-1041) 

● Errors occurred when importing a schedule from older versions (16 and 17) of 
Primavera P6. (TIL-1032) 

● You could not import a Primavera P6.xml file. (TIL-1018) 

Graphics/Display/Views 

● TILOS crashed when you tried to open a Time-Distance View with a unique name. 
(TIL-1089) 

● Views were extremely slow/unresponsive (e.g., you could not scroll), even when all 
tasks, grids, and objects were removed and cell display options were disabled. 
(TIL-1079) 

● Text rotation in a task template was not being applied to tasks using the template in a 
view. (TIL-989) 
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● Distance scale changes made in a sector profile were not being applied when you 
changed the sector type priority. (TIL-988, TIL-881) 

Tasks and Scheduling 

● Sector-based speeds and quantities were not working; the quantity calculation was 
incorrect and there was no variable of speed by sector profile. (TIL-1085, TIL-1086) 

● In a schedule with ASAP and ALAP tasks, a task was displayed as ​critical ​despite the fact 
that it had both free float and total float parameters. (TIL-1069) 

● Task segment text for non-working time ignored the non-working time color and 
description (from Options), and text information for grid lines based on sector profiles 
were incorrectly positioned. (TIL-1067) 

● A black (rather than transparent) line appeared for the non-working section of a task. 
(TIL-1065) 

● TILOS closed unexpectedly when you rescheduled certain projects. (TIL-1063) 

● Sector profile scale lines were not displayed correctly until you changed the sector 
type. This was likely due to having copied sector types, rather than using + to add them. 
Distance scales were wrong when you copied sector types. This was due to the view not 
refreshing automatically. (TIL-1046,TIL-1048 ) 

● Calculating duration by speed from a sector profile, tasks lost their durations when you 
changed their direction. (TIL-1033) 

● Rather than throwing an error, TILOS closed unexpectedly when you added a task 
without progress that used progress by distance-split. (TIL-907, TIL-911) 

● When you created a new project from a template, the start and end distances specified 
in Settings were not used. The dates were applied, but the distance was multiplied 
incorrectly. (TIL-1049) 

● When a file was converted from version 9.1 to 10.3 MR3, filter dates were wrong. 
(TIL-1037) 

● TILOS crashed when you rescheduled after deleting the last link you added. (TIL-1024) 

● Using Calculate lag by predecessor, you could not define a ling lag based on the 
predecessor calendar. Instead, TILOS would recalculate the link based on the successor 
calendar. (TIL-1022) 

 

 Trimble                TILOS 10.3 MR1 Release Notes               5 of 10 



 

Gantt Charts 

● The Display Sub-project Summary checkbox had no effect, so it was removed from the 
Gantt Chart Settings dialog. (TIL-1074) 

● TILOS crashed when you added a task to a Gantt chart. (TIL-1036) 

● When you printed a Gantt chart from certain files, task and layer colors appeared only 
on the first page, and the second page included only the border. (TIL-1017) 

● When you exchanged a task template in a column where the token template name was 
used, the task template remained unchanged. (TIL-985) 

Mass Haul 

● Mass area rectangles overlapped (so appeared as one) and were not sized based on 
their quantities. (TIL-1082) 

● TILOS crashed when you created multiple haulage areas and then pressed Control + Z 
several times to undo the areas. (TIL-967) 

● Enabling the Display Haul Quantity option on the Mass Haulage Presentation Diagram 
tab caused the Display Haul Quantity bar to go above the mass area’s rectangle. 
(TIL-910) 

● Overhaul distance was not automatically recalculated when you added it to a specific 
cut/fill area. (TIL-862) 

Histograms 

● When trying to print a histogram with the Display Diagram option disabled for all (so 
that only tables are visible), when you changed the zoom level, the diagrams 
redisplayed. (TIL-1029) 

● TILOS crashed when a linked graphic was no longer in the original source folder. 
(TIL-992) 

Printing 

● TILOS exchanged the orientation for height/width when using the Set Page Size option. 
Also, when scaled by distance, profiles were displayed but not printed. And the right 
margin (inherited from the View settings) was not being applied. (TIL-1020) 

● A Gantt chart would not print on a single page. (TIL-888) 
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Other 

● Clashes were not being detected when task lines and rectangles overlapped. (TIL-1051) 

● The Russian language edition was not fully translated: Some interface text had never 
been translated, and some previously translated interface text was again in English. 
(TIL-1045) 

● TILOS froze when running on a Citrix Server on Windows Server 2016 due to the Folder 
Redirection > AppData(Roaming) > Setting: Basic (Redirect everyone’s folder to the 
same location). (TIL-1039) 

● The Create Calendar for Group option was not working properly: day definitions were 
being overwritten and changed, and after using the function, the file closed and could 
not be re-opened. (TIL-976) 

● Also see ​Known Issues​ below. 

 

 ​Other 

Known issues 

● MS Project does not support sub-divided calendars exported from TILOS. As a 
workaround, you can introduce a small break between each setup/work interval. 
(TIL-1097) 

● If you have more than one version of TILOS installed, when you right-click on an HSP 
project file and choose Open with, the latest installed version of TILOS is not available 
as an option (occasionally, the option may appear). This is a Microsoft​®​ Windows 
operating system issue. (TIL-853) 

● From resolved Printing issues:​ In rare cases, when you try to print a Gantt chart, 
either it will not be positioned correctly on the page (causing part of the chart to be cut 
off) or the size may be incorrect (so more pages are printed). To fix this: 

1. In TILOS Explorer, open the Gantt chart you want to print. 
2. Select File > Print on the menu. 
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3. In the Print pane, select a print template in the Template view list. 

 
4. Close the Print pane. 
5. In TILOS Explorer > Views > Print Form for Gantt Chart, double-click the same 

print template. 
6. Select File > Print on the menu to re-open the Print pane. 
7. Check the Set page size to view size box. 

 
8. Close the Print pane. 
9. Re-open the Gantt chart and try printing again. Anything else you print in the 

same project will print as expected. 

● This reported issue works as designed:  In a summary task with linked child tasks, if a 
link is driving, the summary task and its children are moved toward the future, but if 
the link is not driving, the summary task and its children do not get moved towards the 
past. 

○ The designed behavior is: Unlinked child tasks in a summary task keep their 
position; tasks under a summary task are not moved if they start later than the 
earliest possible start date for the summary task. 

● It was reported that using the TILOS MS Project (XML) exporter, a distance-split, 
progressed task was imported into MS Project with incorrect data; the duration, start 
date, and end date were wrong. After investigation, it was determined that the XML 
exported from TILOS was correct, but that MS Project recalculations (likely based on 
resource availability) caused the error. This is a problem outside of TILOS. The 
workaround is to avoid importing resources into MS Project.  
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Supported Languages 

TILOS program interface is available in these languages: 

● Chinese (Mandarin) 
● English 
● French 
● German 
● Hungarian 
● Italian 

● Korean 
● Polish 
● Russian 
● Spanish 
● Turkish 

It is possible to run more than one language edition on the same computer. 

TILOS program help is available in these languages: 

● English 
● German   
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Reaching Sales, Support, and the Community 
For more information, please use these resources: 

Trimble TILOS Community 

Search for the latest content, ask a question, see answers to other user questions, start a 
discussion, or post your own helpful content.  

https://community.trimble.com/community/find-answers/civil-engineering-and-construction/scheduling 

Technical Support Hotline 

● Hours: 
o Monday to Thursday: 08.30 am - 5:30 pm (GMT +1) 
o Friday: 08.30 am - 1:00 pm (GMT +1) 

● Phone: +49 721 - 4647 - 2829 (Europe) 
● Email: ​TILOS@trimble.com 

When contacting the hotline, please be prepared the following information: 

● Your software product ID 
● Your company name and address 
● The current software version 
● Which operating system (OS) you are working on and the assigned User Rights 

Sales and Product Information 

● Europe phone: +49 721 - 4647 - 2829 
● Americas phone: (937) 245-5154 
● Americas toll-free phone: (800) 361-1249 
● Web site: ​https://construction.trimble.com/products-and-solutions/TILOS 

 

 
 
 
 
 
 
 
Trimble 2020 All rights reserved. Duplication is strictly prohibited. All trademarks registered. 
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